Wrong displayed characters äöüß /text attributes displayed in brackets

Home Forums Guestbook Add-On Wrong displayed characters äöüß /text attributes displayed in brackets

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #925

    Hello together,

    today I purchased Guestbook and afterwards Guestbook Add-On. But I have two problems:

    When I write an entry to guestbook and want to use e.g. Bold characters (or other text attributes), the text doesn´t appear as bold text but is only written like this:
    [b]Test Test[/b]…this is quite bad and uncomfortable for readability!
    Even the received emails for admin and author do have only the brackets!
    However after publishing, the word is displayed properly bold!

    I´m living in Germany and so I´m using german umlauts äöü and ß. But these characters are shown as ���� in incoming emails to admin and author as well. I tried to change the umlauts (vowels) in “Guestbook/Settings/Announcements” (e.g. Gästebucheintrag >>> Gästebuch) but after saving changes, those emails still contain wrong characters ���� and when going back to “Settings/Announcements” the old entries still appear!

    I´m using Firefox, but problems are appearing on IE and Chrome as well (and Android Smartphone)!

    Hope, somebody can help
    Best regards

    Marcel Pol

    Hi Peter,
    1. I understand BBcode might not be the most readable for people. I am sorry, but I don’t plan on adding real html to the editor, I just don’t feel comfortable doing that.
    I can understand you would want it readable in email as well, but most emails in WordPress are plain text, I think html email is not the default. Adding html tags to plain text email will make it less readable.

    2. Hmm, that is annoying and not supposed to happen. That only happens in emails, not on the website when reading or editing entries? If it is only in email, could you forward such an email to marcel@timelord.nl? That way I can look if anything is wrong. What could be happening is the wrong encoding for email, which might be a header or the content itself.
    If it only happens in email, I don’t think the problem is in this plugin, but somewhere in the generating, sending or receiving of the email.

    Marcel Pol

    Hmm, I was afraid of it. The forwarded email has everything in UTF-8, but I cannot see the original email header or email content encoding.
    I am not sure if you would be okay with that, but could you add a test user with Author role, and subscribe it to notifications?
    I am not allowed to log into your website, and I don’t know how easy it is doable to make it so that I cannot log in as Author.
    Myself I have used this plugin to disable login:

    Disable User Login

    If you are looking for translations, they are in /wp-content/languages/plugins/gwolle-gb*
    But It is not about the translation strings, but also about the content of the entry, so I think the fault is not in the translation files.


    ok Marcel,

    give me a few minutes, I will prepare….

    Marcel Pol

    Ouch, I am not really the right person for Microsoft Outlook :)

    It could be that this resolves it:
    Setting the default language to Western European, which is Microsoft language for an encoding that supports only a subset of UTF-8.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.